hp-snmp-agents on debian 6.0 (squeeze)

30 Mar

hp-snmp-agents error: Service snmp has to be enabled to start service hp-snmp-agents

If you get an error like:

Setting up hp-snmp-agents (8.5.0.1.1-2) ...
insserv: Service snmp has to be enabled to start service hp-snmp-agents
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing hp-snmp-agents (--configure):
subprocess installed post-installation script returned error exit status 1

Edit the file:

/var/lib/dpkg/info/hp-snmp-agents.postinst

and change the “update-rc.d “ to “update-rc.d -f “, then
apt-get -f install
and you should be back in business.

(copied 1-on-1 from craighoffman)

One thought on “hp-snmp-agents on debian 6.0 (squeeze)

  1. I’d recommend fixing the dependency in the init script instead. The problem is actually in the file:

    /etc/init.d/hp-snmp-agents

    One of the Required-Start parameters is incorrect: “snmp” should be changed to “snmpd”. This is the correct dependency for the SNMP daemon. Previously this was simply ignored without dependency based boot support.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: